<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#"><head> <meta charset="utf-8"> <meta http-equiv="X-UA-Compatible" content="IE=edge"> <meta name='viewport' content='width=device-width, initial-scale=1.0, user-scalable=0' /> <title>Scientists Say Blockchain Systems Might Qualify as Living Beings</title> <meta name="description" content='Blockchain, when paired with a type of AI, might meet fundamental criteria for life! This could be the beginning of a shift in scientific paradigms.'> <meta name="keywords" content="blockchain, living, life, ai, ann, neural networks, cryptocurrencies, digital currencies, emergent life, origin of life, artificial intelligence, complex systems, industrial revolution, scientific paradigm, philosophy, philosophy of science"> <meta property="og:title" content="Scientists Say Blockchain Systems Might Qualify as Living Beings" /> <meta property="og:description" content="Blockchain, when paired with a type of AI, might meet fundamental criteria for life! This could be the beginning of a shift in scientific paradigms." /> <meta property="og:type" content="article" /> <meta property="og:url" content="https://interestingengineering.com/blockchain-systems-ai-living-beings" /> <meta property="og:image" content="https://inteng-storage.s3.amazonaws.com/img/iea/zDOZKBB3Gk/sizes/blockchain-systems-ai-living-beings_md.jpg" /> <meta property="og:image:alt" content="Scientists Say Blockchain Systems Might Qualify as Living Beings" /> <meta property="fb:pages" content="139188202817559"/> <meta property="fb:app_id" content="467815213795758"/> <link rel="shortcut icon" href="https://assets.interestingengineering.com/icons-v2/favicon.ico?v=15"> <link rel="apple-touch-icon" sizes="57x57" href="https://assets.interestingengineering.com/icons-v2/apple-icon-57x57.png?v=15"> <link rel="apple-touch-icon" sizes="60x60" href="https://assets.interestingengineering.com/icons-v2/apple-icon-60x60.png?v=15"> <link rel="apple-touch-icon" sizes="72x72" href="https://assets.interestingengineering.com/icons-v2/apple-icon-72x72.png?v=15"> <link rel="apple-touch-icon" sizes="76x76" href="https://assets.interestingengineering.com/icons-v2/apple-icon-76x76.png?v=15"> <link rel="apple-touch-icon" sizes="114x114" href="https://assets.interestingengineering.com/icons-v2/apple-icon-114x114.png?v=15"> <link rel="apple-touch-icon" sizes="120x120" href="https://assets.interestingengineering.com/icons-v2/apple-icon-120x120.png?v=15"> <link rel="apple-touch-icon" sizes="144x144" href="https://assets.interestingengineering.com/icons-v2/apple-icon-144x144.png?v=15"> <link rel="apple-touch-icon" sizes="152x152" href="https://assets.interestingengineering.com/icons-v2/apple-icon-152x152.png?v=15"> <link rel="apple-touch-icon" sizes="180x180" href="https://assets.interestingengineering.com/icons-v2/apple-icon-180x180.png?v=15"> <link rel="icon" type="image/png" sizes="192x192" href="https://assets.interestingengineering.com/icons-v2/android-icon-192x192.png?v=15"> <link rel="icon" type="image/png" sizes="32x32" href="https://assets.interestingengineering.com/icons-v2/favicon-32x32.png?v=15"> <link rel="icon" type="image/png" sizes="96x96" href="https://assets.interestingengineering.com/icons-v2/favicon-96x96.png?v=15"> <link rel="icon" type="image/png" sizes="16x16" href="https://assets.interestingengineering.com/icons-v2/favicon-16x16.png?v=15"> <link rel="manifest" href="https://assets.interestingengineering.com/manifest.json"> <meta name="msapplication-TileColor" content="#007FC0"> <meta name="msapplication-TileImage" content="https://assets.interestingengineering.com/icons-v2/ms-icon-144x144.png?v=15"> <meta name="theme-color" content="#007FC0">  <meta name="csrf-token" content="ohJn0nlXjAlJ1fNVR3yrhPzmqQSsjYQW1jgvTckH"> <link rel="dns-prefetch" href="https://inteng-storage.s3.amazonaws.com"> <link rel="dns-prefetch" href="//www.google-analytics.com"> <link rel="dns-prefetch" href="//stackpath.bootstrapcdn.com"> <link rel="dns-prefetch" href="//www.facebook.com"> <link rel="dns-prefetch" href="//connect.facebook.net"> <link rel="dns-prefetch" href="//pagead2.googlesyndication.com"> <link rel="dns-prefetch" href="//securepubads.g.doubleclick.net"> <link rel="dns-prefetch" href="//www.google-analytics.com"> <link rel="dns-prefetch" href="//www.googletagservices.com"> <link rel="dns-prefetch" href="//adserver-us.adtech.advertising.com"> <link rel="dns-prefetch" href="//hbopenbid.pubmatic.com"> <link rel="dns-prefetch" href="//www.stack-sonar.com"> <link rel="dns-prefetch" href="//www.googletagmanager.com">  <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://spellsalsa.com/v2rlz0Ro2yAAzpbn279qhf6ZMkhMRNO3zmuMU5tHz6fDr9HNOv0m7vxE",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");;;!(function(a,i,t,e){var n=i[t];!(function r(){if(!window.frames[e]){var t=a.body;if(t){var n=a.createElement("iframe");n.style.display="none",n.name=e,t.appendChild(n)}else setTimeout(r,5)}})();var c=[];function o(i){if(i&&i.data){var e,t="__tcfapiCall",c="string"==typeof i.data&&0<=i.data.indexOf(t);(e=c?((function a(t){try{return JSON.parse(t)}catch(n){}})(i.data)||{})[t]:(i.data||{})[t])&&n(e.command,e.version,function(t,n){var a={__tcfapiReturn:{returnValue:t,success:n,callId:e.callId}};i.source.postMessage(c?JSON.stringify(a):a,"*")},e.parameter)}}"function"!=typeof n&&(n=i[t]=i[t]||function f(){for(var t=[],n=0;n<arguments.length;n++)t.push(arguments[n]);if(!t.length)return c;"ping"===t[0]?t[2]({gdprAppliesGlobally:!!i.__cmpGdprAppliesGlobally,cmpLoaded:!1,cmpStatus:"stub"}):0<t.length&&c.push(t)},i.addEventListener?i.addEventListener("message",o,!1):i.attachEvent&&i.attachEvent("onmessage",o))})(document,window,"__tcfapi","__tcfapiLocator");;!(function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if((function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}})(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://troubledtail.com/v2bhn7rS-aXN8Expl-4wrnxTv72cv8bJH6gW67gyyn6rDIGSCUmmUwC4hYeIOELNVBYMK3cuD",t.parentNode.insertBefore(o,t)})(document,window,"__uspapi","__uspapiLocator","script");</script> <script> admiral("after", "cmp.loaded", function (data) { var gptWasAdded; function addGPTTag() { if (gptWasAdded) return; var el = document.createElement("script"); el.src = "https://securepubads.g.doubleclick.net/tag/js/gpt.js"; el.async = true; document.body.append(el); gptWasAdded = true; } if (data.tcData && data.tcData.gdprApplies) { if ( data.tcData.purpose && data.tcData.purpose.consents && data.tcData.purpose.consents[1] ) { addGPTTag(); } else { admiral("after", "cmp.updated", addGPTTag); } } else { addGPTTag(); } }); </script> <script src="https://assets.interestingengineering.com/assets/plugins/lazyload.min.js"></script> <link rel="alternate" type="application/atom+xml" href="/feed/atom" title="Interesting Engineering RSS Feed">  <link href="https://assets.interestingengineering.com/assets/plugins/bootstrap/css/bootstrap.min.css" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/common.min.css?v=15" rel="stylesheet"> <link href="//stackpath.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css" rel="stylesheet" > <link href="https://assets.interestingengineering.com/color.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/plugins/iziToast/dist/css/iziToast.min.css" rel="stylesheet"> <script src="https://assets.interestingengineering.com/assets/plugins/jquery/jquery-3.3.1.min.js"></script> <link href="https://assets.interestingengineering.com/assets/css_v2/content.min.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/post.min.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/dv2.min.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/lists.min.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/newsletter.min.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/subs.min.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/home.min.css?v=15" rel="stylesheet"> <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"WebSite","keywords":["news","tech news","engineering news","science news","innovation news"],"inLanguage":"en-US","publisher":{"@type":"Organization","name":"Interesting Engineering","url":"https:\/\/interestingengineering.com","description":"Interesting Engineering is a cutting edge, leading community designed for all lovers of engineering, technology and science.","logo":{"@type":"ImageObject","height":"192","width":"192","url":"https:\/\/inteng-storage.s3.amazonaws.com\/icons\/nice-highres.png"},"sameAs":["https:\/\/www.facebook.com\/interestingengineering","https:\/\/twitter.com\/IntEngineering","https:\/\/www.linkedin.com\/company\/interestingengineering\/","https:\/\/www.instagram.com\/interestingengineering\/","https:\/\/www.youtube.com\/channel\/UCEuiOszNd6msGgqsD0f9YAQ","https:\/\/intengineering.tumblr.com\/","https:\/\/t.me\/ieofficial","https:\/\/flipboard.com\/@intengineering"],"potentialAction":{"@type":"SearchAction","target":"https:\/\/interestingengineering.com\/s\/search?q={search_term_string}","query-input":"required name=search_term_string"}},"mainEntityOfPage":{"@type":"CollectionPage","id":"https:\/\/interestingengineering.com"}}</script> <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"Article","url":"https:\/\/interestingengineering.com\/blockchain-systems-ai-living-beings","dateCreated":"2021-08-12T19:27:32-05:00","datePublished":"2021-08-12T19:27:32-05:00","dateModified":"2021-08-12T19:27:32-05:00","keywords":["blockchain","living","life","ai","ann","neural networks","cryptocurrencies","digital currencies","emergent life","origin of life","artificial intelligence","complex systems","industrial revolution","scientific paradigm","philosophy","philosophy of science"],"headline":"Blockchain, when paired with a type of AI, might meet fundamental criteria for life! This could be the beginni","name":"Scientists Say Blockchain Systems Might Qualify as Living Beings","description":"Blockchain, when paired with a type of AI, might meet fundamental criteria for life! This could be the beginning of a shift in scientific paradigms.","articleSection":"Innovation","image":{"@type":"ImageObject","height":"213","width":"500","url":"https:\/\/inteng-storage.s3.amazonaws.com\/img\/iea\/zDOZKBB3Gk\/sizes\/blockchain-systems-ai-living-beings_resize_md.jpg"},"publisher":{"@type":"Organization","name":"Interesting Engineering","url":"https:\/\/interestingengineering.com","description":"","logo":{"@type":"ImageObject","height":"389","width":"744","url":"https:\/\/inteng-storage.s3.amazonaws.com\/icons\/nice-highres.png"},"sameAs":["https:\/\/www.facebook.com\/interestingengineering","https:\/\/twitter.com\/IntEngineering","https:\/\/www.linkedin.com\/company\/interestingengineering\/","https:\/\/www.instagram.com\/interestingengineering\/","https:\/\/plus.google.com\/+Interestingengineeringofficial\/posts","https:\/\/www.youtube.com\/channel\/UCEuiOszNd6msGgqsD0f9YAQ","https:\/\/intengineering.tumblr.com\/","https:\/\/t.me\/ieofficial","https:\/\/flipboard.com\/@intengineering"]},"author":{"@type":"Person","name":"Brad Bergan","url":"https:\/\/interestingengineering.com\/author\/brad-bergan"},"creator":{"@type":"Person","name":"Brad Bergan","url":"https:\/\/interestingengineering.com\/author\/brad-bergan"},"speakable":{"@type":"SpeakableSpecification","cssSelector":[".content-title",".content-text"]},"mainEntityOfPage":{"@type":"WebPage","id":"https:\/\/interestingengineering.com\/blockchain-systems-ai-living-beings"}}</script> <link rel="dns-prefetch" href="//graph.facebook.net"> <link rel="canonical" href="https://interestingengineering.com/blockchain-systems-ai-living-beings" /> <link href="https://assets.interestingengineering.com/assets/plugins/jssocials/jssocials-theme-flat.css" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/plugins/jssocials/jssocials.css" rel="stylesheet"> <script> var c = 0; </script> <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script> <meta property="og:image:width" content="864" /> <meta property="og:image:height" content="486" /> <meta property="article:published_time" content="2021-08-12T19:27:32-05:00" /> <meta property="article:modified_time" content="2021-08-12T19:27:32-05:00" /> <meta property="og:updated_time" content="2021-08-12T19:27:32-05:00" /> <meta name="twitter:card" content="summary_large_image" /> <meta name="twitter:site" content="@IntEngineering" /> <meta name="twitter:title" content="Scientists Say Blockchain Systems Might Qualify as Living Beings" /> <meta name="twitter:description" content="Blockchain, when paired with a type of AI, might meet fundamental criteria for life! This could be the beginning of a shift in scientific paradigms." /> <meta name="twitter:image" content="https://inteng-storage.s3.amazonaws.com/img/iea/zDOZKBB3Gk/sizes/blockchain-systems-ai-living-beings_md.jpg" /> <meta name="twitter:creator" content="@IntEngineering"> <link rel="amphtml" href="https://amp.interestingengineering.com/blockchain-systems-ai-living-beings"> <script type="text/javascript" src="//dsh7ky7308k4b.cloudfront.net/publishers/interestingengineeringcom_new.min.js"></script> <script> window.googletag = window.googletag || {cmd: []}; window.googletag.cmd.push (function () { window.googletag.pubads (). setTargeting ('globalKey', 'hpads'); }); </script> <script>!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);</script>  <script> window.ie = {"csrfToken":"ohJn0nlXjAlJ1fNVR3yrhPzmqQSsjYQW1jgvTckH"}; url = "https://interestingengineering.com/blockchain-systems-ai-living-beings"; </script> <script> (function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){ (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n), z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z) })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar'); stackSonar('stack-connect-p', '285'); </script> <script> var dataLayer = [{ 'irefID': "IEA1590747", 'iauthor': "Brad Bergan", 'icat1': "Innovation", 'icat2': "", 'iseocontent': "1", 'iparagraphcount': "10", 'iwordcount': "831", 'ilogin': "0", 'ipublishdate': "20210812", 'ipublishtime': "19:27:32", 'itag': "blockchain, living, life, ai, ann, neural networks, cryptocurrencies, digital currencies, emergent life, origin of life, artificial intelligence, complex systems, industrial revolution, scientific paradigm, philosophy, philosophy of science", 'ifromurl': "https://interestingengineering.com", 'ipagetype': "detail", 'ibrand': "", 'ifotocount': "", 'ivideocount': "1", 'iAdblockStatus': "0", }];</script><script> (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer','GTM-MM4VBX4');</script>  <script type="text/javascript" > (function(m,e,t,r,i,k,a){m[i]=m[i]||function(){(m[i].a=m[i].a||[]).push(arguments)}; m[i].l=1*new Date();k=e.createElement(t),a=e.getElementsByTagName(t)[0],k.async=1,k.src=r,a.parentNode.insertBefore(k,a)}) (window, document, "script", "https://mc.yandex.ru/metrika/tag.js", "ym"); ym(53308081, "init", { clickmap:true, trackLinks:true, accurateTrackBounce:true }); </script>   <script> !function(f,b,e,v,n,t,s) {if(f.fbq)return;n=f.fbq=function(){n.callMethod? n.callMethod.apply(n,arguments):n.queue.push(arguments)}; if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0'; n.queue=[];t=b.createElement(e);t.async=!0; t.src=v;s=b.getElementsByTagName(e)[0]; s.parentNode.insertBefore(t,s)}(window, document,'script', 'https://connect.facebook.net/en_US/fbevents.js'); fbq('init', '657415324884715'); fbq('track', 'PageView'); </script>  <script type='text/javascript'> (function() { var _sf_async_config = window._sf_async_config = (window._sf_async_config || {}); _sf_async_config.uid = 66054; _sf_async_config.domain = 'interestingengineering.com'; _sf_async_config.useCanonical = true; _sf_async_config.useCanonicalDomain = true; function loadChartbeat() { var e = document.createElement('script'); var n = document.getElementsByTagName('script')[0]; e.type = 'text/javascript'; e.async = true; e.src = '//static.chartbeat.com/js/chartbeat.js'; n.parentNode.insertBefore(e, n); } loadChartbeat(); })(); </script> </head><body class="header-bar"> <noscript><img src="https://mc.yandex.ru/watch/53308081" style="position:absolute; left:-9999px;" alt="Yandex"/></noscript> <noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=657415324884715&ev=PageView&noscript=1" alt="Facebook"/></noscript> <div id="pg-wp">  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MM4VBX4" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>   <header id="header" class="navbar-fixed-top"> <nav class="navbar navbar-default" id="slide-nav"> <div class="container-fluid"> <div class="navbar-header"> <button type="button" id="nav-icon" name="Navigation" aria-label="Navigation" class="navbar-toggle collapsed text-hide"> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </button> <a class="navbar-brand text-hide" title="Interesting Engineering" href="https://interestingengineering.com">Interesting Engineering</a> </div> <div id="slidemenu"> <ul class="nav navbar-nav main-nav"><li class="active"><a href="https://interestingengineering.com/innovation"><span>Innovation</span></a><span class="color-innovation"></span></li><li><a href="https://interestingengineering.com/science"><span>Science</span></a></li><li><a href="https://interestingengineering.com/culture"><span>Culture</span></a></li><li><a href="https://interestingengineering.com/health"><span>Health</span></a></li><li><a href="https://interestingengineering.com/transportation"><span>Transportation</span></a></li><li><a href="https://interestingengineering.com/video"><span><i class="fa fa-play menu-sign" aria-hidden="true">&nbsp;</i>Videos</span></a></li><li><a href="https://interestingengineering.com/diy"><span>DIY</span></a></li></ul> </div> <div class="visible-lg-block visible-md-block gradient"></div> <div id="sidebar"> <div id="sidemenu"> <ul class="nav navbar-nav navbar-right socialmenu"> <li class="divider-vertical visible-md-inline-block visible-lg-inline-block"></li> <li><a href="https://www.facebook.com/interestingengineering" target="_blank" title="Facebook"><i class="fa fa-facebook" aria-hidden="true"></i></a></li> <li><a href="https://twitter.com/IntEngineering" target="_blank" title="Twitter"><i class="fa fa-twitter" aria-hidden="true"></i></a></li> <li><a href="https://www.youtube.com/channel/UCEuiOszNd6msGgqsD0f9YAQ" target="_blank" title="Youtube"><i class="fa fa-youtube-play" aria-hidden="true"></i></a></li> <li><a href="https://www.instagram.com/interestingengineering/" target="_blank" title="Instagram"><i class="fa fa-instagram" aria-hidden="true"></i></a></li> <li><a href="https://www.linkedin.com/company/interestingengineering/" target="_blank" title="Linkedin"><i class="fa fa-linkedin" aria-hidden="true"></i></a></li> <li><a href="https://interestingengineering.com/feed" target="_blank" title="Rss"><i class="fa fa-rss" aria-hidden="true"></i></a></li> <li><a href="https://t.me/ieofficial" target="_blank" title="Telegram"><i class="fa fa-telegram" aria-hidden="true"></i></a></li> <li class="hidden-md hidden-lg"><a href="https://flipboard.com/@intengineering" title="Flipboard" class="icon-flipboard-white"></a></li> <li class="hidden-sm hidden-xs"><a href="https://flipboard.com/@intengineering" title="Flipboard" class="icon-flipboard"></a></li> <li>&nbsp;&nbsp;&nbsp;</li> </ul> </div> <div class="mobile-menu"> <form id="search" class="header-box" action="https://interestingengineering.com/s/search"> <button class="search-button" type="submit" aria-label="Search"><i class="fa fa-search" aria-hidden="true"></i></button> <input type="search" name="q" id="search-input" placeholder="Search"> <input type="hidden" name="sort" value="new"> <button class="search-toggle-button" aria-label="Search Toggle" type="button" name="search-toggle"><i class="fa fa-search" aria-hidden="true"></i></button> </form> </div> </div> </div> </nav> <div class="category-bar clearfix color-innovation "> <div class="category-name color-innovation"> <a href="https://interestingengineering.com/innovation">Innovation</a> </div> </div> <div id="navbar-height-col" style="left: -248px;"></div> </header> <div class="overlay"></div> <main id="page-content"> <div class="ias-push"> <div class="hidden">1590747</div> <div class="ias-push-item"> <script> var gtmData = ""; </script> <div class="adW"> <div class="adC spBg"> <span class="adL">Advertisement</span>   <div class="adA hidden-xs hidden-sm" style='height:250px; width:970px;'> <div id='div-gpt-ad-interestingengineeringcom38210'></div> </div>   <div class="adA hidden-md hidden-lg" style='height:50px; width:320px;'> <div id='div-gpt-ad-interestingengineeringcom34971'></div> </div> </div> </div> <div class="content-wrp container row clearfix"> <div class="content-header column-left"> <div class="content-category clearfix"> <div class="category-title-light small pull-left text-uppercase"> <ol class="simple-nav"> <li> <a href="https://interestingengineering.com/innovation"> <span>Innovation</span> </a> </li> </ol> <span class="color-innovation"></span> </div> </div> <h1 class="content-title" data-url="https://interestingengineering.com/blockchain-systems-ai-living-beings" data-id="blockchain-systems-ai-living-beings">Scientists Say Blockchain Systems Might Qualify as Living Beings</h1> <p class="content-sub-title">And if so, they can't be 'switched off.'</p> <div class="content"> <div class="content-tag tag-top border-bottom"> <div class="post-tag"> <a class="clearfix pull-left" href="https://interestingengineering.com/author/brad-bergan" rel="author"> <img data-pin-nopin="true" src="https://inteng-storage.s3.amazonaws.com/avatars/WeGRW50tmyzf_thumb.jpg" alt="Brad Bergan" class="hidden-xs img-circle"> </a> <div class="clearfix"> <span>By&nbsp;</span> <a href="https://interestingengineering.com/author/brad-bergan" rel="author" class="m-0">Brad Bergan</a> </div> <span>Aug 12, 2021 </span> </div> <div class="content-share"> <div class="jssocials-share jssocials-share-facebook"> <a target="_blank" rel="nofollow" href="https://facebook.com/sharer/sharer.php?u=https%3A%2F%2Finterestingengineering.com%2Fblockchain-systems-ai-living-beings" class="jssocials-share-link"> <i class="fa fa-facebook jssocials-share-logo"></i> </a> </div> <div class="jssocials-share jssocials-share-twitter"> <a target="_blank" rel="nofollow" href="https://twitter.com/share?url=https%3A%2F%2Finterestingengineering.com%2Fblockchain-systems-ai-living-beings" class="jssocials-share-link"> <i class="fa fa-twitter jssocials-share-logo"></i> </a> </div> <div class="jssocials-share jssocials-share-linkedin"> <a target="_blank" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Finterestingengineering.com%2Fblockchain-systems-ai-living-beings" class="jssocials-share-link"> <i class="fa fa-linkedin jssocials-share-logo"></i> </a> </div> <div class="jssocials-share jssocials-share-reddit"> <a target="_blank" rel="nofollow" href="https://www.reddit.com/submit?url=https%3A%2F%2Finterestingengineering.com%2Fblockchain-systems-ai-living-beings" class="jssocials-share-link"> <i class="fa fa-reddit-alien jssocials-share-logo"></i> </a> </div> </div> </div> <article class="content clearfix"> <div class="content-image"> <picture> <img class="img-responsive" src="https://inteng-storage.s3.amazonaws.com/img/iea/zDOZKBB3Gk/sizes/blockchain-systems-ai-living-beings_resize_md.jpg" alt="Scientists Say Blockchain Systems Might Qualify as Living Beings"> </picture> <div class="image-info row clearfix"> <span class="pull-left">An abstract image of organized, glowing particles.</span> <span class="pull-right"><a href="https://www.istockphoto.com/photo/abstract-data-background-gm1254825742-366901887" target="_blank" rel="nofollow">shulz / iStock</a></span> </div> </div> <div class="content-text clearfix"> <p id="p-0">Life is precious, exhaustingly fragile, and, tragically, short.</p><p id="p-1">Or is it?</p><p id="p-2">The most common observations in biological life forms might have a lot in common with computational systems, hinting at a new definition of life, according to a recent study <a class="underline border-color-innovation" href="https://link.springer.com/article/10.1007/s11084-021-09608-1" rel="nofollow" target="_blank">published in the journal&nbsp;<em>Origins of Life and Evolution of Biospheres</em></a>.</p><p id="p-3">And, while this might feel like a bizarre move, the technological revolution in AI, digital currency, and automated infrastructure of the coming years might simply escape our grasp without a fundamental shift in scientific paradigms.</p><h2>Blockchain technology paired with AI could 'satisfy' basic definitions of life</h2><p id="p-4">There is some evidence that links the order witnessed in biological systems to computational ones, according to Senior Scientist Oleg Abramov of the Planetary Science Institute, which is partially funded by NASA's Habitable Worlds program. Abramov is also the lead author of the recent study. "A promising direction for future research [lies in the] development of mathematical theories that calculate how biological systems order themselves," he explained in <a class="underline border-color-innovation" href="https://www.psi.edu/news/orginsoflife" rel="nofollow" target="_blank">a blog post on the institute's official website</a>. Co-Authors Kristin Bebell and Stephen Mojzsis, the latter of whom is director of a newly-established Origins Research Institute at the Research Center for Astronomy and Earth Sciences in Budapest, Hungary, also contributed to the recent paper, which emphasized a multidisciplinary approach to the notion of defining "life."</p><div class="embed-ad" id="ad-4"><div class="vad-player"><script type="text/javascript">if(screen.width>1013){var videoScript=document.createElement('script');videoScript.setAttribute('id','8ef5cecd6a3d4c789cc419bac10c84b2'),videoScript.textContent='cnxps.cmd.push(function () { cnxps({ playerId: "98e195e3-9365-4b73-9f85-323744f63bd1"}).render("8ef5cecd6a3d4c789cc419bac10c84b2");});';}else{ var videoScript=document.createElement('script');videoScript.setAttribute('src','https://player.anyclip.com/anyclip-widget/lre-widget/prod/v1/src/lre.js'),videoScript.setAttribute('pubname','interestingengineeringcom'),videoScript.setAttribute('widgetname','001w000001ZTZiS_1505');}var currentScript=document.currentScript||document.scripts[document.scripts.length-1];currentScript.parentNode.insertBefore(videoScript,currentScript.nextSibling);</script></div></div><p id="p-5">This included theory, modeling, and observations, with the former involving principles of self-organization and evolution throughout a wide spectrum of lifeforms. This enabled the authors to provide a tweaked definition of biological systems <a class="underline border-color-innovation" href="https://interestingengineering.com/how-will-humans-create-artificial-life" rel="dofollow" target="_blank" data-id="embedded internal links" data-type="link" data-url="https://interestingengineering.com/how-will-humans-create-artificial-life">based on first principles</a>, instead of cohesive consensus (which can be groundless, speaking logically). "This work presents observations of a blockchain-based distributed virtual machine (dVM) composed of thousands of nodes, or computers, which collectively function as a global general-purpose computer that, for practical purposes, cannot be turned off," explained Abramov, in the blog post. "Observations in this study demonstrate that such dVMs possess characteristics with biological systems. For example, our observations reveal a number of functional and structural similarities between the blockchain and DNA, a self-replicating molecule that is the genetic blueprint for all known life."</p><div class="embed-ad" id="ad-5"><div class="adW b-margin-20 visible-xs visible-sm"><div class="adC spBg"><span class="adL">Advertisement</span><div class="adA" id="div-gpt-ad-interestingengineeringcom38215" style="height:280px; width:336px;"></div></div></div></div><p id="p-6">"The blockchain is an append-only data structure composed of subunits called blocks, which are permanently 'chained' together using advanced cryptography," explained Abramov. "In practice, it is an immutable medium which contains instructions in the form of computer code and is replicated across thousands of nodes much like DNA in cells." The paper also says blockchain-based systems, while not generally considered as lifeforms, nevertheless exhibit some properties of life. These include responding to the environment, growth, change, self-regulation, and replications. Conceptualizing these processes of self-sufficiency and self-organization to constitute an "organism," the researchers regarded this technology as an operationally closed system that could, at least in theory, satisfy all definitions of life. And blockchain isn't the only life-like technology, according to the researchers.</p><p id="p-7"><span class="embed-responsive embed-responsive-16by9"><iframe title="YouTube video player" src="https://www.youtube.com/embed/-aNW08ahM68" allowfullscreen="allowfullscreen" class="embed-responsive-item"></iframe></span></p><h2>The fourth industrial revolution might require a new scientific paradigm</h2><p id="p-8">Artificial intelligence (AI) based on artificial neural networks (ANNs) might further enable this nascent reassessment of highly sophisticated computing technology as a form of life, read the blog post. These systems might even possess several crucial advantages over biological life, like a capacity to more efficiently pass down traits into offspring, in addition to extremely enhanced speed, accuracy, and redundancy of the genetic carrier. And, breaking with our carbon-based human lives, technological forms of life could enjoy <a class="underline border-color-innovation" href="https://interestingengineering.com/scientists-claim-space-megastructures-could-resurrect-the-dead" rel="dofollow" target="_blank" data-id="embedded internal links" data-type="link" data-url="https://interestingengineering.com/scientists-claim-space-megastructures-could-resurrect-the-dead">a potentially unlimited lifespan</a> (assuming the Earth isn't completely destroyed). "Public blockchain-based dVMs provide an uncontained environment for the development of artificial general intelligence, with the potential to self-direct their evolution," concluded the blog post from the Planetary Science Institute.</p><div class="embed-ad" id="ad-8"><div class="adW b-margin-20 visible-xs visible-sm"><div class="adC spBg"><span class="adL">Advertisement</span><div class="adA" id="div-gpt-ad-interestingengineeringcom38216" style="height:280px; width:336px;"></div></div></div></div><p id="p-9">If life-like <a class="underline border-color-innovation" href="https://interestingengineering.com/to-mine-crypto-or-not-to-mine" rel="dofollow" target="_blank" data-id="embedded internal links" data-type="link" data-url="https://interestingengineering.com/to-mine-crypto-or-not-to-mine">elements of the blockchain</a>, which is similar in function to human DNA, are joined with ANN-based AI (which coordinates operations like a brain), the study authors suspect the creation of wholly new complex systems might be on the horizon. Systems that, on the most fundamental level of first principles and self-regulating order, might be indistinguishable from the biological life we study every day. This is an extremely unconventional study, which dodges some serious philosophical problems of defining life and consciousness by mostly altering the definition of the former. But, with an economy increasingly at the mercy of digital currencies and many industries becoming increasingly automated, reframing next-gen technologies with a broader scientific paradigm may, at least pragmatically, help the human race better grasp <a class="underline border-color-innovation" href="https://interestingengineering.com/smart-cities-climate-change" rel="dofollow" target="_blank" data-id="embedded internal links" data-type="link" data-url="https://interestingengineering.com/smart-cities-climate-change">what the next industrial revolution is all about</a>.</p> </div> </article> </div> <div class="clearfix"> <div class="adW hidden-xs hidden-sm"> <div class="adC spBg"> <span class="adL">Advertisement</span>   <div class="adA" style='min-width: 300px; display:flex; justify-content: center; align-items:center;'> <div id='div-gpt-ad-interestingengineeringcom38222'></div> </div> </div> </div> </div> <div class="news-icon"> <div class="news-container"> <span>Follow Us on</span> <div class="news-button-container"> <div class="google-news"> <a rel="nofollow" target="_blank" href="https://news.google.com/u/1/publications/CAAqBwgKMMualAsw2MapAw"></a> </div> <div class="news-break"> <a rel="nofollow" target="_blank" href="https://www.newsbreak.com/@c/512488"></a> </div> </div> </div> </div> <div class="container-fluid slim-subscription"> <div class="form-wrapper"> <form method="POST" action="https://interestingengineering.com/subscription" accept-charset="UTF-8" class="subscription sbs-form small-box text-center" style="width:100%;"><input name="_token" type="hidden" value="ohJn0nlXjAlJ1fNVR3yrhPzmqQSsjYQW1jgvTckH"> <div class="clearfix"> <div class="clearfix b-margin-20"> <h2>Stay on top of the latest engineering news</h2> <span>Just enter your email and we’ll take care of the rest:</span> </div> <div class="clearfix b-margin-10"> <div class="frm"> <div class="input-group"> <input class="form-control" placeholder="Enter your email address" name="email" type="email"> </div> <button type="submit" class="btn btn-info">SUBSCRIBE</button> </div> </div> </div> <p class="ua-nl">By subscribing, you agree to our <a href="https://interestingengineering.com/terms-of-service" target="_blank">Terms of Use</a> and <a href="https://interestingengineering.com/privacy-policy" target="_blank">Privacy Policy</a>. You may unsubscribe at any time.</p> </form> </div> </div> <div class="recommended-wrapper clearfix"> <div class="recommended-list"> <div class="category-title-light big"> <h2>Sponsored Stories</h2> <span class="color-orange"></span> </div> <div class="OUTBRAIN" data-widget-id="AR_2" data-src="https://interestingengineering.com/blockchain-systems-ai-living-beings"></div> </div> </div> <div class="tb-margin"> <div id="ac-lre-player-ph"> <div id="ac-lre-player"></div> </div> <script>if(screen.width<=1013){var videoScript=document.createElement('script');videoScript.setAttribute('id','fa96ecfc1197481b861a000d28e4950c'),videoScript.textContent='cnxps.cmd.push(function () { cnxps({ playerId: "149f35a0-1e3f-48ab-a165-a7f7150d1237"}).render("fa96ecfc1197481b861a000d28e4950c");});';}else{ var videoScript=document.createElement('script');videoScript.setAttribute('src','https://player.anyclip.com/anyclip-widget/lre-widget/prod/v1/src/lre.js'),videoScript.setAttribute('pubname','interestingengineeringcom'),videoScript.setAttribute('widgetname','001w000001ZTZiS_1263');}var currentScript=document.currentScript||document.scripts[document.scripts.length-1];currentScript.parentNode.insertBefore(videoScript,currentScript.nextSibling);</script> </div> <div class="recommended-list clearfix"> <div class="category-title-light big"> <h2>Recommended</h2> <span class="color-ice-blue"></span> </div> <div class="recommended-wrapper clearfix"> <article class="post"> <a class="post-image" href="https://interestingengineering.com/universe-finite-donut"><img alt="Astrophysicists Say Our Universe Might Actually Be Finite" src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/img/iea/rV6nWQm1wX/sizes/universe-finite-donut_xs.jpg" class="img-responsive"></a> <div class="post-header"> <a href="https://interestingengineering.com/science" title="Science" class="category-title category-title-sm color-science">Science</a> <h2 class="clearfix"><a title="Astrophysicists Say Our Universe Might Actually Be Finite" href="https://interestingengineering.com/universe-finite-donut">Astrophysicists Say Our Universe Might Actually Be Finite</a></h2> <div class="post-tag clearfix"> <a class="clearfix pull-left" title="Brad Bergan" href="https://interestingengineering.com/author/brad-bergan" rel="author"> <img src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/avatars/WeGRW50tmyzf_small.jpg" class="img-circle" alt="Brad Bergan"> </a> <div class="clearfix"> <a title="Brad Bergan" href="https://interestingengineering.com/author/brad-bergan" rel="author">Brad Bergan</a> </div> <span>3 weeks ago</span> </div> </div> </article> <article class="post"> <a class="post-image" href="https://interestingengineering.com/black-holes-might-lead-to-the-birth-of-new-universes"><img alt="Scientists Say Black Holes Might Lead to the Birth of New Universes" src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/img/iea/jvwv5mYD6x/sizes/black-holes-might-lead-to-the-birth-of-new-universes_xs.jpg" class="img-responsive"></a> <div class="post-header"> <a href="https://interestingengineering.com/science" title="Science" class="category-title category-title-sm color-science">Science</a> <h2 class="clearfix"><a title="Scientists Say Black Holes Might Lead to the Birth of New Universes" href="https://interestingengineering.com/black-holes-might-lead-to-the-birth-of-new-universes">Scientists Say Black Holes Might Lead to the Birth of New Universes</a></h2> <div class="post-tag clearfix"> <a class="clearfix pull-left" title="Brad Bergan" href="https://interestingengineering.com/author/brad-bergan" rel="author"> <img src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/avatars/WeGRW50tmyzf_small.jpg" class="img-circle" alt="Brad Bergan"> </a> <div class="clearfix"> <a title="Brad Bergan" href="https://interestingengineering.com/author/brad-bergan" rel="author">Brad Bergan</a> </div> <span>2 months ago</span> </div> </div> </article> <article class="post"> <a class="post-image" href="https://interestingengineering.com/nasa-chief-says-covid-19-come-from-lab"><img alt="The New NASA Chief Says COVID-19 Might Have &#039;Come From a Lab&#039;" src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/img/iea/XD6K8brzwv/sizes/nasa-chief-says-covid-19-come-from-lab_xs.jpg" class="img-responsive"></a> <div class="post-header"> <a href="https://interestingengineering.com/health" title="Health" class="category-title category-title-sm color-news">Health</a> <h2 class="clearfix"><a title="The New NASA Chief Says COVID-19 Might Have &#039;Come From a Lab&#039;" href="https://interestingengineering.com/nasa-chief-says-covid-19-come-from-lab">The New NASA Chief Says COVID-19 Might Have &#039;Come From a Lab&#039;</a></h2> <div class="post-tag clearfix"> <a class="clearfix pull-left" title="Brad Bergan" href="https://interestingengineering.com/author/brad-bergan" rel="author"> <img src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/avatars/WeGRW50tmyzf_small.jpg" class="img-circle" alt="Brad Bergan"> </a> <div class="clearfix"> <a title="Brad Bergan" href="https://interestingengineering.com/author/brad-bergan" rel="author">Brad Bergan</a> </div> <span>2 months ago</span> </div> </div> </article> <article class="post hidden-md hidden-lg"> <a class="post-image" href="https://interestingengineering.com/elon-musk-spacex-starship-sn16-hypersonic-flight"><img alt="Elon Musk Says SpaceX&#039;s Starship SN16 Might Jump to Hypersonic Flight" src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/img/iea/V0OyWydp6Q/sizes/elon-musk-spacex-starship-sn16-hypersonic-flight_xs.jpg" class="img-responsive"></a> <div class="post-header"> <a href="https://interestingengineering.com/innovation" title="Innovation" class="category-title category-title-sm color-innovation">Innovation</a> <h2 class="clearfix"><a title="Elon Musk Says SpaceX&#039;s Starship SN16 Might Jump to Hypersonic Flight" href="https://interestingengineering.com/elon-musk-spacex-starship-sn16-hypersonic-flight">Elon Musk Says SpaceX&#039;s Starship SN16 Might Jump to Hypersonic Flight</a></h2> <div class="post-tag clearfix"> <a class="clearfix pull-left" title="Brad Bergan" href="https://interestingengineering.com/author/brad-bergan" rel="author"> <img src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/avatars/WeGRW50tmyzf_small.jpg" class="img-circle" alt="Brad Bergan"> </a> <div class="clearfix"> <a title="Brad Bergan" href="https://interestingengineering.com/author/brad-bergan" rel="author">Brad Bergan</a> </div> <span>1 month ago</span> </div> </div> </article> </div> </div> </div> <div class="column-right"> <div class="trending spo-right visible-md visible-lg b-margin-20"> <div class="adW visible-md visible-lg"> <div class="adC spBg"> <span class="adL">Advertisement</span>   <div class="adA" style='height:600px; width:300px;'> <div id='div-gpt-ad-interestingengineeringcom38212'></div> </div> </div> </div> </div> <div class="hidden">831</div> <div class="OUTBRAIN" data-widget-id="GS_8" data-src="https://interestingengineering.com/blockchain-systems-ai-living-beings" data-ob-template="InterestingEngineering"></div> </div> <div class="column-right sticky sticky-box"> <div class="adW visible-md visible-lg t-margin"> <div class="adC spBg"> <span class="adL">Advertisement</span> <div class="center-block"> <div class="b-margin-10" id="div-gpt-ad-interestingengineeringcom38241"></div> <div id="div-gpt-ad-interestingengineeringcom38242"></div> </div> </div> </div> </div> </div> </div> </div> <div class="container"> <div id="next-content"> <a href="https://interestingengineering.com/this-company-turns-shipping-containers-into-sustainable-swimming-pools" title="next" class="next-content"></a> </div> </div>  <footer id="site-footer" class="container-fluid"> <div class="footer-top-wrapper"> <div class="container"> <div class="footer-column-left clearfix"> <nav id="footer-ie-nav"> <span>INTERESTING ENGINEERING</span> <div class="centered-nav"> <ul class="simple-nav"><li><a href="https://interestingengineering.com/about-us">About Us</a><li><a href="https://interestingengineering.com/advertise">Advertise</a><li><a href="https://interestingengineering.com/jobs">Jobs</a><li><a href="https://interestingengineering.com/newsletter">Newsletter</a><li><a href="https://interestingengineering.com/contact-us">Contact Us</a></li></ul> </div> </nav> <nav id="footer-main-nav" class="hidden-xs"> <span>CATEGORIES</span> <ul class="simple-nav"> <li><a href="https://interestingengineering.com/innovation" title="Innovation">Innovation</a></li> <li><a href="https://interestingengineering.com/science" title="Science">Science</a></li> <li><a href="https://interestingengineering.com/culture" title="Culture">Culture</a></li> <li><a href="https://interestingengineering.com/health" title="Health">Health</a></li> <li><a href="https://interestingengineering.com/transportation" title="Transportation">Transportation</a></li> </ul> </nav> </div> </div> </div> <div class="footer-bottom-wrapper"> <nav class="container"> <span class="copyright">© Copyright 2021 | Interesting Engineering, Inc. | All Rights Reserved</span> <div class="footer-pp-menu"> <ul class="simple-nav"><li><a href="https://interestingengineering.com/terms-of-service">Terms of Service</a><li><a href="https://interestingengineering.com/policies">Policies</a></li></ul> </div> </nav> </div> </footer> <div id="cookie-warning"> <div class="container"> <button class="cookie-warning-close">x</button> <span class="pull-left"> We use cookies to ensure you get the best experience on our website. Please <a href="https://interestingengineering.com/privacy-policy">review our Privacy Policy</a> for more information and/or to change your cookie settings at any time. If you continue to use this site, you consent to our use of cookies. </span> <div class="cookie-warning-btn-wrp"> <a href="https://interestingengineering.com/privacy-policy#settings" class="btn btn-warning">COOKIE SETTINGS</a> </div> </div> </div>  <div class="modal fade" id="newsletter-modal" tabindex="-1" role="dialog"> <div class="modal-dialog" role="document"> <div class="modal-content"> <div class="modal-header"> <button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true">&times;</span></button> </div> <div class="modal-body text-center newsletter-container"> <div class="header-container"> <h3 class="h1">Stay on top of<br>the latest<br>engineering news</h3> </div> <form method="POST" action="https://interestingengineering.com/subscription" accept-charset="UTF-8" class="text-center sbs-form"><input name="_token" type="hidden" value="ohJn0nlXjAlJ1fNVR3yrhPzmqQSsjYQW1jgvTckH"> <label class="input-group"> <input class="form-control no-border" aria-label="Email" placeholder="Enter your email address" name="email" type="email"> </label> <button type="submit" class="btn btn-success newsletter-submit no-border" data-push-category="Daily Newsletter Popup"></button> <p class="ua-nl ng">By subscribing, you agree to our <a href="https://interestingengineering.com/terms-of-service" target="_blank">Terms of Use</a> and <a href="https://interestingengineering.com/privacy-policy" target="_blank">Privacy Policy</a>. You may unsubscribe at any time.</p> </form> </div> </div> </div> </div> </main>    <script defer src="https://assets.interestingengineering.com/assets/plugins/bootstrap/js/bootstrap.min.js"></script> <script defer src="https://assets.interestingengineering.com/assets/plugins/iziToast/dist/js/iziToast.min.js"></script> <script defer src="https://assets.interestingengineering.com/assets/plugins/stickyfill.min.js"></script> <script src="https://www.dwin2.com/pub.649979.min.js"></script> <script src="https://assets.interestingengineering.com/assets/plugins/jquery-ias.min.js"></script> <script src="https://assets.interestingengineering.com/assets/plugins/sly.min.js"></script> <script> $(function() { if($('.article-bottom-ad').length) { $(window).on('resize scroll', function() { var abAd = $('.article-bottom-ad'); if (abAd.isInViewport()) { if(abAd.data('is-active') != '1') { setEvent('Sponsored (Banner)',abAd.find('a').data('title'),'Impression'); abAd.data('is-active','1'); } } }); } $(document).on('click touch', '.trending-item > a', function(){ window.dataLayer.push({ 'event': 'gaEvent', 'Category': 'More at Interesting Engineering Unit', 'Label': $(this).text(), 'Action': 'Click', 'nonInteraction': true }); }); $(document).on('click touch', '.trending-topic-title', function(){ window.dataLayer.push({ 'event': 'gaEvent', 'Category': 'More at Interesting Engineering Unit', 'Label': 'More at Interesting Engineering', 'Action': 'Click', 'nonInteraction': true }); }); $.displayNewsletterForm = function() { $('.arrow-down').toggleClass('active'); $('#newsletterContent').slideToggle('fast'); setEvent('In Article Newsletter Unit','CTA Title','Click'); }; var categoryMenu = $('.category-menu'); if($('.sub-category-list').length) { $('.sub-category-list').width($(window).width() - $('.category-name').width()-20).show(); categoryMenu.width($(window).width() - $('.category-name').width()-80); var sly = new Sly(categoryMenu, { horizontal: 1, itemNav: 'centered', activateOn: 'click', mouseDragging: 1, touchDragging: 1, releaseSwing: 1, activatePageOn: 'click', speed: 300, elasticBounds: 1, dragHandle: 1, dynamicHandle: 1, clickBar: 1, prevPage: $('.controls').find('.prevPage'), nextPage: $('.controls').find('.nextPage') }).init(); var $pos = 0; sly.on('moveStart', function (eventName) { if($pos < sly.pos.dest) { setEvent('Category Navigation Bar','Right Arrow','Click'); $pos = sly.pos.dest; } else if($pos > sly.pos.dest) { setEvent('Category Navigation Bar','Left Arrow','Click'); $pos = sly.pos.dest; } }); $('.category-menu > ul > li > a').on('click',function(){ setEvent('Category Navigation Bar',$(this).text(),'Click'); }); } if($('.sub-category-list').length) { $(window).on('resize scroll', function() { $('.sub-category-list').width($(window).width() - $('.category-name').width()-20); categoryMenu.width($(window).width() - $('.category-name').width()-80); sly.reload(); }); } }); $(window).on("load", function() { $('#sticky__sidebar').height($(document).height() - ($('#site-footer').height() + 234)); }); var iasPush = jQuery.ias({ container: '.ias-push', item: '.ias-push-item', pagination: '#next-content', next: '.next-content', delay: 0, negativeMargin: 200 }); iasPush.extension(new IASPagingExtension()); iasPush.extension(new IASHistoryExtension({ prev: '.prev a' })); iasPush.extension(new IASNoneLeftExtension({ html: '<div class="container tb-margin-10"><a disabled class="btn btn-lg btn-primary load-more black-bottom-shadow">{text}</a></div>' })); iasPush.extension(new IASSpinnerExtension({ src: 'https://assets.interestingengineering.com/assets/img/loading-blocks.svg' })); iasPush.extension(new IASTriggerExtension({ html: '<div class="container tb-margin-10"><a class="btn btn-lg btn-primary load-more black-bottom-shadow">NEXT ARTICLE</a></div>' })); iasPush.on('load', function(event) { c = c+1; event.url = event.url + "?c="+c; }); iasPush.on('rendered', function(items) { $(items).each(function() { var $this = this; var $contentData = $($this).find('.content-title'); var url = $contentData.data('url'); var title = $contentData.text(); myLazyLoad.update(); OBR.extern.researchWidget(); }); $('#sticky__sidebar').height($(document).height()); setEvent('Article','Next Article Button','Click'); dataLayer.push(gtmData); }); </script> <script defer src="https://assets.interestingengineering.com/assets/js/main.min.js?v=15"></script> <script> $(function (){ $(document).on('click touch', '.cookie-settings', function(){ $('#cookie-warning').hide(); __cmp('displayConsentUi'); window.dataLayer.push({ 'event': 'gaEvent', 'Category': 'GDPR Cookie Bar', 'Label': 'Settings Button', 'Action': 'Click', 'nonInteraction': true }); }); }); </script> <script> $(window).on("load", function () { setTimeout( function() { $('#newsletter-modal').modal(); $('#header').css('z-index',1000); setEvent('Daily Newsletter Popup','Popup Impressions','Impression'); }, 30000); $('#newsletter-modal').on('hidden.bs.modal', function (e) { $.get( "/setNewsletter"); setEvent('Daily Newsletter Popup','Close Button','Click'); }); }); </script> </div></body> </html>