<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#"><head> <meta charset="utf-8"> <meta http-equiv="X-UA-Compatible" content="IE=edge"> <meta name='viewport' content='width=device-width, initial-scale=1.0, user-scalable=0' /> <title>DARPA Is Building a Portable Atomic Clock With Trillionth of a Second Accuracy</title> <meta name="description" content='DARPA announced the ROCkN program which aims to build a&nbsp;super-accurate optical atomic clock compact enough to fit inside a military aircraft.'> <meta name="keywords" content="Atomic clock, DARPA, ultra-accurate"> <meta property="og:title" content="DARPA Is Building a Portable Atomic Clock With Trillionth of a Second Accuracy" /> <meta property="og:description" content="DARPA announced the ROCkN program which aims to build a&nbsp;super-accurate optical atomic clock compact enough to fit inside a military aircraft." /> <meta property="og:type" content="article" /> <meta property="og:url" content="https://interestingengineering.com/darpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy" /> <meta property="og:image" content="https://inteng-storage.s3.amazonaws.com/img/iea/QjOddNnmOd/sizes/darpa_md.jpeg" /> <meta property="og:image:alt" content="DARPA Is Building a Portable Atomic Clock With Trillionth of a Second Accuracy" /> <meta property="fb:pages" content="139188202817559"/> <meta property="fb:app_id" content="467815213795758"/> <link rel="shortcut icon" href="https://assets.interestingengineering.com/icons-v2/favicon.ico?v=15"> <link rel="apple-touch-icon" sizes="57x57" href="https://assets.interestingengineering.com/icons-v2/apple-icon-57x57.png?v=15"> <link rel="apple-touch-icon" sizes="60x60" href="https://assets.interestingengineering.com/icons-v2/apple-icon-60x60.png?v=15"> <link rel="apple-touch-icon" sizes="72x72" href="https://assets.interestingengineering.com/icons-v2/apple-icon-72x72.png?v=15"> <link rel="apple-touch-icon" sizes="76x76" href="https://assets.interestingengineering.com/icons-v2/apple-icon-76x76.png?v=15"> <link rel="apple-touch-icon" sizes="114x114" href="https://assets.interestingengineering.com/icons-v2/apple-icon-114x114.png?v=15"> <link rel="apple-touch-icon" sizes="120x120" href="https://assets.interestingengineering.com/icons-v2/apple-icon-120x120.png?v=15"> <link rel="apple-touch-icon" sizes="144x144" href="https://assets.interestingengineering.com/icons-v2/apple-icon-144x144.png?v=15"> <link rel="apple-touch-icon" sizes="152x152" href="https://assets.interestingengineering.com/icons-v2/apple-icon-152x152.png?v=15"> <link rel="apple-touch-icon" sizes="180x180" href="https://assets.interestingengineering.com/icons-v2/apple-icon-180x180.png?v=15"> <link rel="icon" type="image/png" sizes="192x192" href="https://assets.interestingengineering.com/icons-v2/android-icon-192x192.png?v=15"> <link rel="icon" type="image/png" sizes="32x32" href="https://assets.interestingengineering.com/icons-v2/favicon-32x32.png?v=15"> <link rel="icon" type="image/png" sizes="96x96" href="https://assets.interestingengineering.com/icons-v2/favicon-96x96.png?v=15"> <link rel="icon" type="image/png" sizes="16x16" href="https://assets.interestingengineering.com/icons-v2/favicon-16x16.png?v=15"> <link rel="manifest" href="https://assets.interestingengineering.com/manifest.json"> <meta name="msapplication-TileColor" content="#007FC0"> <meta name="msapplication-TileImage" content="https://assets.interestingengineering.com/icons-v2/ms-icon-144x144.png?v=15"> <meta name="theme-color" content="#007FC0">  <meta name="csrf-token" content="DnAWwIDm8wloaqFoWX7GChOJBZ2lQgjYrFKCEBF2"> <link rel="dns-prefetch" href="https://inteng-storage.s3.amazonaws.com"> <link rel="dns-prefetch" href="//www.google-analytics.com"> <link rel="dns-prefetch" href="//stackpath.bootstrapcdn.com"> <link rel="dns-prefetch" href="//www.facebook.com"> <link rel="dns-prefetch" href="//connect.facebook.net"> <link rel="dns-prefetch" href="//pagead2.googlesyndication.com"> <link rel="dns-prefetch" href="//securepubads.g.doubleclick.net"> <link rel="dns-prefetch" href="//www.google-analytics.com"> <link rel="dns-prefetch" href="//www.googletagservices.com"> <link rel="dns-prefetch" href="//adserver-us.adtech.advertising.com"> <link rel="dns-prefetch" href="//hbopenbid.pubmatic.com"> <link rel="dns-prefetch" href="//www.stack-sonar.com"> <link rel="dns-prefetch" href="//www.googletagmanager.com">  <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://spellsalsa.com/v2rlz0Ro2yAAzpbn279qhf6ZMkhMRNO3zmuMU5tHz6fDr9HNOv0m7vxE",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");;;!(function(a,i,t,e){var n=i[t];!(function r(){if(!window.frames[e]){var t=a.body;if(t){var n=a.createElement("iframe");n.style.display="none",n.name=e,t.appendChild(n)}else setTimeout(r,5)}})();var c=[];function o(i){if(i&&i.data){var e,t="__tcfapiCall",c="string"==typeof i.data&&0<=i.data.indexOf(t);(e=c?((function a(t){try{return JSON.parse(t)}catch(n){}})(i.data)||{})[t]:(i.data||{})[t])&&n(e.command,e.version,function(t,n){var a={__tcfapiReturn:{returnValue:t,success:n,callId:e.callId}};i.source.postMessage(c?JSON.stringify(a):a,"*")},e.parameter)}}"function"!=typeof n&&(n=i[t]=i[t]||function f(){for(var t=[],n=0;n<arguments.length;n++)t.push(arguments[n]);if(!t.length)return c;"ping"===t[0]?t[2]({gdprAppliesGlobally:!!i.__cmpGdprAppliesGlobally,cmpLoaded:!1,cmpStatus:"stub"}):0<t.length&&c.push(t)},i.addEventListener?i.addEventListener("message",o,!1):i.attachEvent&&i.attachEvent("onmessage",o))})(document,window,"__tcfapi","__tcfapiLocator");;!(function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if((function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}})(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://troubledtail.com/v2bhn7rS-aXN8Expl-4wrnxTv72cv8bJH6gW67gyyn6rDIGSCUmmUwC4hYeIOELNVBYMK3cuD",t.parentNode.insertBefore(o,t)})(document,window,"__uspapi","__uspapiLocator","script");</script> <script> admiral("after", "cmp.loaded", function(data) { var PGWasAdded; function addPGwrapper() { if (PGWasAdded) return; var el = document.createElement("script"); el.src = "https://dsh7ky7308k4b.cloudfront.net/publishers/interestingengineeringcom_new.min.js"; el.async = true; document.head.append(el); PGWasAdded = true; } if (data.tcData && data.tcData.gdprApplies) { if ( data.tcData.purpose && data.tcData.purpose.consents && data.tcData.purpose.consents[1] ) { addPGwrapper(); } else { admiral("after", "cmp.updated", addPGwrapper); } } else { addPGwrapper(); } }); </script> <script src="https://assets.interestingengineering.com/assets/plugins/lazyload.min.js"></script> <link rel="alternate" type="application/atom+xml" href="/feed/atom" title="Interesting Engineering RSS Feed">  <link href="https://assets.interestingengineering.com/assets/plugins/bootstrap/css/bootstrap.min.css" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/common.min.css?v=15" rel="stylesheet"> <link href="//stackpath.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css" rel="stylesheet" > <link href="https://assets.interestingengineering.com/color.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/plugins/iziToast/dist/css/iziToast.min.css" rel="stylesheet"> <script src="https://assets.interestingengineering.com/assets/plugins/jquery/jquery-3.3.1.min.js"></script> <link href="https://assets.interestingengineering.com/assets/css_v2/content.min.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/post.min.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/dv2.min.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/lists.min.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/newsletter.min.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/subs.min.css?v=15" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/css_v2/home.min.css?v=15" rel="stylesheet"> <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"WebSite","keywords":["news","tech news","engineering news","science news","innovation news"],"inLanguage":"en-US","publisher":{"@type":"Organization","name":"Interesting Engineering","url":"https:\/\/interestingengineering.com","description":"Interesting Engineering is a cutting edge, leading community designed for all lovers of engineering, technology and science.","logo":{"@type":"ImageObject","height":"192","width":"192","url":"https:\/\/inteng-storage.s3.amazonaws.com\/icons\/nice-highres.png"},"sameAs":["https:\/\/www.facebook.com\/interestingengineering","https:\/\/twitter.com\/IntEngineering","https:\/\/www.linkedin.com\/company\/interestingengineering\/","https:\/\/www.instagram.com\/interestingengineering\/","https:\/\/www.youtube.com\/channel\/UCEuiOszNd6msGgqsD0f9YAQ","https:\/\/intengineering.tumblr.com\/","https:\/\/t.me\/ieofficial","https:\/\/flipboard.com\/@intengineering"],"potentialAction":{"@type":"SearchAction","target":"https:\/\/interestingengineering.com\/s\/search?q={search_term_string}","query-input":"required name=search_term_string"}},"mainEntityOfPage":{"@type":"CollectionPage","id":"https:\/\/interestingengineering.com"}}</script> <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"Article","url":"https:\/\/interestingengineering.com\/darpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy","dateCreated":"2022-01-31T12:02:00-05:00","datePublished":"2022-01-31T12:02:00-05:00","dateModified":"2022-01-31T12:06:49-05:00","keywords":["Atomic clock","DARPA","ultra-accurate"],"headline":"DARPA announced the ROCkN program which aims to build a\u00a0super-accurate optical atomic clock compact enough to","name":"DARPA Is Building a Portable Atomic Clock With Trillionth of a Second Accuracy","description":"DARPA announced the ROCkN program which aims to build a\u00a0super-accurate optical atomic clock compact enough to fit inside a military aircraft.","articleSection":"Innovation","image":{"@type":"ImageObject","height":"213","width":"500","url":"https:\/\/inteng-storage.s3.amazonaws.com\/img\/iea\/QjOddNnmOd\/sizes\/darpa_resize_md.jpeg"},"publisher":{"@type":"Organization","name":"Interesting Engineering","url":"https:\/\/interestingengineering.com","description":"","logo":{"@type":"ImageObject","height":"389","width":"744","url":"https:\/\/inteng-storage.s3.amazonaws.com\/icons\/nice-highres.png"},"sameAs":["https:\/\/www.facebook.com\/interestingengineering","https:\/\/twitter.com\/IntEngineering","https:\/\/www.linkedin.com\/company\/interestingengineering\/","https:\/\/www.instagram.com\/interestingengineering\/","https:\/\/plus.google.com\/+Interestingengineeringofficial\/posts","https:\/\/www.youtube.com\/channel\/UCEuiOszNd6msGgqsD0f9YAQ","https:\/\/intengineering.tumblr.com\/","https:\/\/t.me\/ieofficial","https:\/\/flipboard.com\/@intengineering"]},"author":{"@type":"Person","name":"Chris Young","url":"https:\/\/interestingengineering.com\/author\/chris-young"},"creator":{"@type":"Person","name":"Chris Young","url":"https:\/\/interestingengineering.com\/author\/chris-young"},"speakable":{"@type":"SpeakableSpecification","cssSelector":[".content-title",".content-text"]},"mainEntityOfPage":{"@type":"WebPage","id":"https:\/\/interestingengineering.com\/darpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy"}}</script> <link rel="dns-prefetch" href="//graph.facebook.net"> <link rel="canonical" href="https://interestingengineering.com/darpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy" /> <link href="https://assets.interestingengineering.com/assets/plugins/jssocials/jssocials-theme-flat.css" rel="stylesheet"> <link href="https://assets.interestingengineering.com/assets/plugins/jssocials/jssocials.css" rel="stylesheet"> <script> var c = 0; </script> <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script> <meta property="og:image:width" content="864" /> <meta property="og:image:height" content="486" /> <meta property="article:published_time" content="2022-01-31T12:02:00-05:00" /> <meta property="article:modified_time" content="2022-01-31T12:06:49-05:00" /> <meta property="og:updated_time" content="2022-01-31T12:06:49-05:00" /> <meta name="twitter:card" content="summary_large_image" /> <meta name="twitter:site" content="@IntEngineering" /> <meta name="twitter:title" content="DARPA Is Building a Portable Atomic Clock With Trillionth of a Second Accuracy" /> <meta name="twitter:description" content="DARPA announced the ROCkN program which aims to build a&nbsp;super-accurate optical atomic clock compact enough to fit inside a military aircraft." /> <meta name="twitter:image" content="https://inteng-storage.s3.amazonaws.com/img/iea/QjOddNnmOd/sizes/darpa_md.jpeg" /> <meta name="twitter:creator" content="@IntEngineering"> <link rel="amphtml" href="https://amp.interestingengineering.com/darpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy"> <script> window.googletag = window.googletag || {cmd: []}; window.googletag.cmd.push (function () { window.googletag.pubads (). setTargeting ('globalKey', 'hpads'); }); </script> <script>!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);</script>  <script> window.ie = {"csrfToken":"DnAWwIDm8wloaqFoWX7GChOJBZ2lQgjYrFKCEBF2"}; url = "https://interestingengineering.com/darpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy"; </script> <script> (function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){ (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n), z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z) })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar'); stackSonar('stack-connect-p', '285'); </script> <script> var dataLayer = [{ 'irefID': "IEA1755693", 'iauthor': "Chris Young", 'icat1': "Innovation", 'icat2': "", 'iseocontent': "0", 'iparagraphcount': "6", 'iwordcount': "473", 'ilogin': "0", 'ipublishdate': "20220131", 'ipublishtime': "12:02:00", 'itag': "Atomic clock, DARPA, ultra-accurate", 'ifromurl': "https://interestingengineering.com", 'ipagetype': "detail", 'ibrand': "", 'ifotocount': "", 'ivideocount': "", 'iAdblockStatus': "0", }];</script><script> (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer','GTM-MM4VBX4');</script>  <script type="text/javascript" > (function(m,e,t,r,i,k,a){m[i]=m[i]||function(){(m[i].a=m[i].a||[]).push(arguments)}; m[i].l=1*new Date();k=e.createElement(t),a=e.getElementsByTagName(t)[0],k.async=1,k.src=r,a.parentNode.insertBefore(k,a)}) (window, document, "script", "https://mc.yandex.ru/metrika/tag.js", "ym"); ym(53308081, "init", { clickmap:true, trackLinks:true, accurateTrackBounce:true }); </script>   <script> !function(f,b,e,v,n,t,s) {if(f.fbq)return;n=f.fbq=function(){n.callMethod? n.callMethod.apply(n,arguments):n.queue.push(arguments)}; if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0'; n.queue=[];t=b.createElement(e);t.async=!0; t.src=v;s=b.getElementsByTagName(e)[0]; s.parentNode.insertBefore(t,s)}(window, document,'script', 'https://connect.facebook.net/en_US/fbevents.js'); fbq('init', '657415324884715'); fbq('track', 'PageView'); </script>  <script type='text/javascript'> (function() { var _sf_async_config = window._sf_async_config = (window._sf_async_config || {}); _sf_async_config.uid = 66054; _sf_async_config.domain = 'interestingengineering.com'; _sf_async_config.useCanonical = true; _sf_async_config.useCanonicalDomain = true; function loadChartbeat() { var e = document.createElement('script'); var n = document.getElementsByTagName('script')[0]; e.type = 'text/javascript'; e.async = true; e.src = '//static.chartbeat.com/js/chartbeat.js'; n.parentNode.insertBefore(e, n); } loadChartbeat(); })(); </script> </head><body class="header-bar"> <noscript><img src="https://mc.yandex.ru/watch/53308081" style="position:absolute; left:-9999px;" alt="Yandex"/></noscript> <noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=657415324884715&ev=PageView&noscript=1" alt="Facebook"/></noscript> <div id="pg-wp">  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MM4VBX4" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>   <header id="header" class="navbar-fixed-top"> <nav class="navbar navbar-default" id="slide-nav"> <div class="container-fluid"> <div class="navbar-header"> <button type="button" id="nav-icon" name="Navigation" aria-label="Navigation" class="navbar-toggle collapsed text-hide"> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </button> <a class="navbar-brand text-hide" title="Interesting Engineering" href="https://interestingengineering.com">Interesting Engineering</a> </div> <div id="slidemenu"> <ul class="nav navbar-nav main-nav"><li class="active"><a href="https://interestingengineering.com/innovation"><span>Innovation</span></a><span class="color-innovation"></span></li><li><a href="https://interestingengineering.com/science"><span>Science</span></a></li><li><a href="https://interestingengineering.com/culture"><span>Culture</span></a></li><li><a href="https://interestingengineering.com/health"><span>Health</span></a></li><li><a href="https://interestingengineering.com/transportation"><span>Transportation</span></a></li><li><a href="https://interestingengineering.com/video"><span><i class="fa fa-play menu-sign" aria-hidden="true">&nbsp;</i>Videos</span></a></li><li><a href="https://interestingengineering.com/diy"><span>DIY</span></a></li></ul> </div> <div class="visible-lg-block visible-md-block gradient"></div> <div id="sidebar"> <div id="sidemenu"> <ul class="nav navbar-nav navbar-right socialmenu"> <li class="divider-vertical visible-md-inline-block visible-lg-inline-block"></li> <li><a href="https://www.facebook.com/interestingengineering" target="_blank" title="Facebook"><i class="fa fa-facebook" aria-hidden="true"></i></a></li> <li><a href="https://twitter.com/IntEngineering" target="_blank" title="Twitter"><i class="fa fa-twitter" aria-hidden="true"></i></a></li> <li><a href="https://www.youtube.com/channel/UCEuiOszNd6msGgqsD0f9YAQ" target="_blank" title="Youtube"><i class="fa fa-youtube-play" aria-hidden="true"></i></a></li> <li><a href="https://www.instagram.com/interestingengineering/" target="_blank" title="Instagram"><i class="fa fa-instagram" aria-hidden="true"></i></a></li> <li><a href="https://www.linkedin.com/company/interestingengineering/" target="_blank" title="Linkedin"><i class="fa fa-linkedin" aria-hidden="true"></i></a></li> <li><a href="https://interestingengineering.com/feed" target="_blank" title="Rss"><i class="fa fa-rss" aria-hidden="true"></i></a></li> <li><a href="https://t.me/ieofficial" target="_blank" title="Telegram"><i class="fa fa-telegram" aria-hidden="true"></i></a></li> <li class="hidden-md hidden-lg"><a href="https://flipboard.com/@intengineering" title="Flipboard" class="icon-flipboard-white"></a></li> <li class="hidden-sm hidden-xs"><a href="https://flipboard.com/@intengineering" title="Flipboard" class="icon-flipboard"></a></li> <li>&nbsp;&nbsp;&nbsp;</li> </ul> </div> <div class="mobile-menu"> <form id="search" class="header-box" action="https://interestingengineering.com/s/search"> <button class="search-button" type="submit" aria-label="Search"><i class="fa fa-search" aria-hidden="true"></i></button> <input type="search" name="q" id="search-input" placeholder="Search"> <input type="hidden" name="sort" value="new"> <button class="search-toggle-button" aria-label="Search Toggle" type="button" name="search-toggle"><i class="fa fa-search" aria-hidden="true"></i></button> </form> </div> </div> </div> </nav> <div class="category-bar clearfix color-innovation "> <div class="category-name color-innovation"> <a href="https://interestingengineering.com/innovation">Innovation</a> </div> </div> <div id="navbar-height-col" style="left: -248px;"></div> </header> <div class="overlay"></div> <main id="page-content"> <div class="ias-push"> <div class="hidden">1755693</div> <div class="ias-push-item"> <script> var gtmData = ""; </script> <div class="adW"> <div class="adC spBg"> <span class="adL">Advertisement</span>   <div class="adA hidden-xs hidden-sm" style='height:250px; width:970px;'> <div id='div-gpt-ad-interestingengineeringcom38210'></div> </div>   <div class="adA hidden-md hidden-lg" style='height:50px; width:320px;'> <div id='div-gpt-ad-interestingengineeringcom34971'></div> </div> </div> </div> <div class="content-wrp container row clearfix"> <div class="content-header column-left"> <div class="content-category clearfix"> <div class="category-title-light small pull-left text-uppercase"> <ol class="simple-nav"> <li> <a href="https://interestingengineering.com/innovation"> <span>Innovation</span> </a> </li> </ol> <span class="color-innovation"></span> </div> </div> <h1 class="content-title" data-url="https://interestingengineering.com/darpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy" data-id="darpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy">DARPA Is Building a Portable Atomic Clock With Trillionth of a Second Accuracy</h1> <p class="content-sub-title">The machines could be strapped to aircraft and even satellites.</p> <div class="content"> <div class="content-tag tag-top border-bottom"> <div class="post-tag"> <a class="clearfix pull-left" href="https://interestingengineering.com/author/chris-young" rel="author"> <img data-pin-nopin="true" src="https://inteng-storage.s3.amazonaws.com/avatars/6UKotck4r9pz_thumb.jpg" alt="Chris Young" class="hidden-xs img-circle"> </a> <div class="clearfix"> <span>By&nbsp;</span> <a href="https://interestingengineering.com/author/chris-young" rel="author" class="m-0">Chris Young</a> </div> <span>Jan 31, 2022 <span class="text-light-gray"> (Updated: Jan 31, 2022 07:06 EST)</span> </span> </div> <div class="content-share"> <div class="jssocials-share jssocials-share-facebook"> <a target="_blank" rel="nofollow" href="https://facebook.com/sharer/sharer.php?u=https%3A%2F%2Finterestingengineering.com%2Fdarpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy" class="jssocials-share-link"> <i class="fa fa-facebook jssocials-share-logo"></i> </a> </div> <div class="jssocials-share jssocials-share-twitter"> <a target="_blank" rel="nofollow" href="https://twitter.com/share?url=https%3A%2F%2Finterestingengineering.com%2Fdarpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy" class="jssocials-share-link"> <i class="fa fa-twitter jssocials-share-logo"></i> </a> </div> <div class="jssocials-share jssocials-share-linkedin"> <a target="_blank" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Finterestingengineering.com%2Fdarpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy" class="jssocials-share-link"> <i class="fa fa-linkedin jssocials-share-logo"></i> </a> </div> <div class="jssocials-share jssocials-share-reddit"> <a target="_blank" rel="nofollow" href="https://www.reddit.com/submit?url=https%3A%2F%2Finterestingengineering.com%2Fdarpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy" class="jssocials-share-link"> <i class="fa fa-reddit-alien jssocials-share-logo"></i> </a> </div> </div> </div> <article class="content clearfix"> <div class="content-image"> <picture> <img class="img-responsive" src="https://inteng-storage.s3.amazonaws.com/img/iea/QjOddNnmOd/sizes/darpa_resize_md.jpeg" alt="DARPA Is Building a Portable Atomic Clock With Trillionth of a Second Accuracy"> </picture> <div class="image-info row clearfix"> <span class="pull-right"><a href="https://www.darpa.mil/news-events/2022-01-20" target="_blank" rel="nofollow">DARPA</a></span> </div> </div> <div class="content-text clearfix"> <p id="p-0">U.S. government agency DARPA announced the&nbsp;Robust Optical Clock Network (ROCkN) program, which aims to build a&nbsp;super-accurate optical atomic clock compact enough to fit inside a military aircraft or field vehicle, a <a class="underline border-color-innovation" href="https://newatlas.com/military/darpas-rockn-program-optical-atomic-clocks-fighter-planes/" rel="nofollow" target="_blank">report from <em>New Atlas</em></a> reveals.</p><p id="p-1">In military operations, nanosecond-level accuracy is required for military craft to fire weapons at high speed and at extreme ranges. Even an error of a billionth of a second could cause a missile to miss its target. To this end, the modern military is heavily reliant on GPS, but the technology isn't always available and it can even be jammed by adversaries.&nbsp;</p><p id="p-2">Atomic clocks could provide a solution by allowing field units to tell the time with ultra-precise accuracy, without the need to connect to GPS. The technology uses a beam of microwaves to measure the frequency of atoms as they change energy state. The most accurate type of atomic clock is the optical atomic clock, which replaces the microwaves with a beam of light, boosting the accuracy by a factor of 100. Optical atomic clocks are so accurate, in fact, that they wouldn't have lost a second over the universe's entire existence of more than 13 billion years.</p><div class="embed-ad" id="ad-2"><div class="vad-player"><script type="text/javascript">if(screen.width>1013){var videoScript=document.createElement('script');videoScript.setAttribute('src','https://player.anyclip.com/anyclip-widget/lre-widget/prod/v1/src/lre.js');videoScript.setAttribute('pubname','interestingengineeringcom');videoScript.setAttribute('widgetname','001w000001ZTZiS_1263');}else{var videoScript=document.createElement('script');videoScript.setAttribute('src','https://player.anyclip.com/anyclip-widget/lre-widget/prod/v1/src/lre.js'),videoScript.setAttribute('pubname','interestingengineeringcom');videoScript.setAttribute('widgetname','001w000001ZTZiS_1505');}var currentScript=document.currentScript||document.scripts[document.scripts.length-1];currentScript.parentNode.insertBefore(videoScript,currentScript.nextSibling);</script></div></div><h2>Portable atomic clocks</h2><p id="p-3">Typically, optical atomic clocks are large cumbersome machines, but DARPA's ROCKn program aims to make them smaller and lighter so they can be fitted into military vehicles, and even satellites.&nbsp;</p><p id="p-4"><span>"The goal is to transition optical atomic clocks from elaborate laboratory configurations to small and robust versions that can operate outside the lab," Tatjana Curcic, program manager in DARPA's Defense Sciences Office, said <a class="underline border-color-innovation" href="https://www.darpa.mil/news-events/2022-01-20" rel="nofollow" target="_blank">in a statement</a>. "If we're successful, these optical clocks would provide a 100x increase in precision, or decrease in timing error, over existing microwave atomic clocks, and demonstrate improved holdover of nanosecond timing precision from a few hours to a month. This program could create many of the critical technologies, components, and demonstrations leading to a potential future networked clock architecture."</span></p><p id="p-5"><span>The technology could have applications for space exploration too. In 2019, NASA activated its&nbsp;<a class="underline border-color-innovation" href="https://interestingengineering.com/nasa-has-activated-its-gps-like-deep-space-atomic-clock" rel="dofollow" target="_blank" data-id="embedded internal links" data-type="link" data-url="https://interestingengineering.com/nasa-has-activated-its-gps-like-deep-space-atomic-clock">Deep Space Atomic Clock</a>, which is crucial for enabling accurate space navigation in the future. Much in the same fashion as military operations, space navigation requires incredibly precise reading over the enormous distances traveled. Portable optical atomic clocks, therefore, have the potential to allow future spacecraft to navigate the cosmos with greater ease.</span></p> </div> </article> </div> <div class="clearfix"> <div class="adW hidden-xs hidden-sm"> <div class="adC spBg"> <span class="adL">Advertisement</span>   <div class="adA" style='min-width: 300px; display:flex; justify-content: center; align-items:center;'> <div id='div-gpt-ad-interestingengineeringcom38222'></div> </div> </div> </div> </div> <div class="news-icon"> <div class="news-container"> <span>Follow Us on</span> <div class="news-button-container"> <div class="google-news"> <a rel="nofollow" target="_blank" href="https://news.google.com/u/1/publications/CAAqBwgKMMualAsw2MapAw"></a> </div> <div class="news-break"> <a rel="nofollow" target="_blank" href="https://www.newsbreak.com/@c/512488"></a> </div> </div> </div> </div> <div class="container-fluid slim-subscription"> <div class="form-wrapper"> <form method="POST" action="https://interestingengineering.com/subscription?utm_source=article_page_signup_box&amp;utm_medium=email_submit&amp;utm_campaign=Newsletter_article_page_box" accept-charset="UTF-8" class="subscription small-box text-center" style="width:100%;"><input name="_token" type="hidden" value="DnAWwIDm8wloaqFoWX7GChOJBZ2lQgjYrFKCEBF2"> <div class="clearfix"> <div class="clearfix b-margin-20"> <h2>Stay on top of the latest engineering news</h2> <span>Just enter your email and we’ll take care of the rest:</span> </div> <div class="clearfix b-margin-10"> <div class="frm"> <div class="input-group"> <input class="form-control" placeholder="Enter your email address" name="email" type="email"> </div> <button type="submit" class="btn btn-info">SUBSCRIBE</button> </div> </div> </div> <p class="ua-nl">By subscribing, you agree to our <a href="https://interestingengineering.com/terms-of-service" target="_blank">Terms of Use</a> and <a href="https://interestingengineering.com/privacy-policy" target="_blank">Privacy Policy</a>. You may unsubscribe at any time.</p> </form> </div> </div> <div class="recommended-wrapper clearfix"> <div class="recommended-list"> <div class="category-title-light big"> <h2>Sponsored Stories</h2> <span class="color-orange"></span> </div> <div class="OUTBRAIN" data-widget-id="AR_2" data-src="https://interestingengineering.com/darpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy"></div> </div> </div> <div class="tb-margin"> <div id="ac-lre-player-ph"> <div id="ac-lre-player"></div> </div> <script>if(screen.width>1013){var videoScript=document.createElement('script');videoScript.setAttribute('id','de702105005745ce85d30e436b8d6fcb');videoScript.textContent='(new Image()).src="https://capi.connatix.com/tr/si?token=ccdf6666-bdf4-4cd8-9b97-ca1bf497568c",cnxps.cmd.push(function(){cnxps({playerId:"ccdf6666-bdf4-4cd8-9b97-ca1bf497568c"}).render("de702105005745ce85d30e436b8d6fcb")});';}else{var videoScript=document.createElement('script');videoScript.setAttribute('id','a098f9cda05349e2ae7babe89bb76c9c');videoScript.textContent='(new Image()).src="https://capi.connatix.com/tr/si?token=bf3a5ece-5767-46e7-8d91-8f81f20b1f89",cnxps.cmd.push(function(){cnxps({playerId:"bf3a5ece-5767-46e7-8d91-8f81f20b1f89"}).render("a098f9cda05349e2ae7babe89bb76c9c")});';}var currentScript=document.currentScript||document.scripts[document.scripts.length-1];currentScript.parentNode.insertBefore(videoScript,currentScript.nextSibling);</script> </div> <div class="recommended-list clearfix"> <div class="category-title-light big"> <h2>Recommended</h2> <span class="color-ice-blue"></span> </div> <div class="recommended-wrapper clearfix"> <article class="post"> <a class="post-image" href="https://interestingengineering.com/a-new-brain-sensor-maps-the-human-brain-with-record-breaking-accuracy"><img alt="A New Brain Sensor Maps the Human Brain With Record-Breaking Accuracy" src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/img/iea/ZKwJl8VEGM/sizes/brain-grid_xs.jpeg" class="img-responsive"></a> <div class="post-header"> <a href="https://interestingengineering.com/innovation" title="Innovation" class="category-title category-title-sm color-innovation">Innovation</a> <h2 class="clearfix"><a title="A New Brain Sensor Maps the Human Brain With Record-Breaking Accuracy" href="https://interestingengineering.com/a-new-brain-sensor-maps-the-human-brain-with-record-breaking-accuracy">A New Brain Sensor Maps the Human Brain With Record-Breaking Accuracy</a></h2> <div class="post-tag clearfix"> <a class="clearfix pull-left" title="Chris Young" href="https://interestingengineering.com/author/chris-young" rel="author"> <img src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/avatars/6UKotck4r9pz_small.jpg" class="img-circle" alt="Chris Young"> </a> <div class="clearfix"> <a title="Chris Young" href="https://interestingengineering.com/author/chris-young" rel="author">Chris Young</a> </div> <span>5 days ago</span> </div> </div> </article> <article class="post"> <a class="post-image" href="https://interestingengineering.com/artificial-intelligence-can-predict-new-designer-drugs-with-90-accuracy"><img alt="Artificial Intelligence Can Predict New Designer Drugs With 90% Accuracy" src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/img/iea/rV6nD2q1OX/sizes/artificial-intelligence-can-predict-new-designer-drugs-with-90-accuracy_xs.jpg" class="img-responsive"></a> <div class="post-header"> <a href="https://interestingengineering.com/innovation" title="Innovation" class="category-title category-title-sm color-innovation">Innovation</a> <h2 class="clearfix"><a title="Artificial Intelligence Can Predict New Designer Drugs With 90% Accuracy" href="https://interestingengineering.com/artificial-intelligence-can-predict-new-designer-drugs-with-90-accuracy">Artificial Intelligence Can Predict New Designer Drugs With 90% Accuracy</a></h2> <div class="post-tag clearfix"> <a class="clearfix pull-left" title="Brad Bergan" href="https://interestingengineering.com/author/brad-bergan" rel="author"> <img src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/avatars/WeGRW50tmyzf_small.jpg" class="img-circle" alt="Brad Bergan"> </a> <div class="clearfix"> <a title="Brad Bergan" href="https://interestingengineering.com/author/brad-bergan" rel="author">Brad Bergan</a> </div> <span>2 months ago</span> </div> </div> </article> <article class="post"> <a class="post-image" href="https://interestingengineering.com/scientists-made-a-breakthrough-with-laser-pulses-of-one-quadrillionth-of-a-second"><img alt="Scientists Made a Breakthrough With Laser Pulses of One Quadrillionth of a Second" src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/img/iea/yrwQJaraON/sizes/light-flashes_xs.jpeg" class="img-responsive"></a> <div class="post-header"> <a href="https://interestingengineering.com/science" title="Science" class="category-title category-title-sm color-science">Science</a> <h2 class="clearfix"><a title="Scientists Made a Breakthrough With Laser Pulses of One Quadrillionth of a Second" href="https://interestingengineering.com/scientists-made-a-breakthrough-with-laser-pulses-of-one-quadrillionth-of-a-second">Scientists Made a Breakthrough With Laser Pulses of One Quadrillionth of a Second</a></h2> <div class="post-tag clearfix"> <a class="clearfix pull-left" title="Chris Young" href="https://interestingengineering.com/author/chris-young" rel="author"> <img src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/avatars/6UKotck4r9pz_small.jpg" class="img-circle" alt="Chris Young"> </a> <div class="clearfix"> <a title="Chris Young" href="https://interestingengineering.com/author/chris-young" rel="author">Chris Young</a> </div> <span>2 months ago</span> </div> </div> </article> <article class="post hidden-md hidden-lg"> <a class="post-image" href="https://interestingengineering.com/el-salvador-builds-20-new-schools-with-bitcoin"><img alt="El Salvador Is Building 20 New Schools. With Bitcoin Profits?" src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/img/iea/EBwmjzDrO0/sizes/btc-edu_xs.jpg" class="img-responsive"></a> <div class="post-header"> <a href="https://interestingengineering.com/culture" title="Culture" class="category-title category-title-sm color-culture">Culture</a> <h2 class="clearfix"><a title="El Salvador Is Building 20 New Schools. With Bitcoin Profits?" href="https://interestingengineering.com/el-salvador-builds-20-new-schools-with-bitcoin">El Salvador Is Building 20 New Schools. With Bitcoin Profits?</a></h2> <div class="post-tag clearfix"> <a class="clearfix pull-left" title="Ameya Paleja" href="https://interestingengineering.com/author/ameya-paleja" rel="author"> <img src="https://assets.interestingengineering.com/assets/img/ie-default_md.png" data-original-set="https://inteng-storage.s3.amazonaws.com/avatars/Uy0OTzksC7lW_small.jpg" class="img-circle" alt="Ameya Paleja"> </a> <div class="clearfix"> <a title="Ameya Paleja" href="https://interestingengineering.com/author/ameya-paleja" rel="author">Ameya Paleja</a> </div> <span>2 months ago</span> </div> </div> </article> </div> </div> </div> <div class="column-right"> <div class="trending spo-right visible-md visible-lg b-margin-20"> <div class="adW visible-md visible-lg"> <div class="adC spBg"> <span class="adL">Advertisement</span>   <div class="adA" style='height:600px; width:300px;'> <div id='div-gpt-ad-interestingengineeringcom38212'></div> </div> </div> </div> </div> <div class="hidden">473</div> <div class="OUTBRAIN" data-widget-id="GS_8" data-src="https://interestingengineering.com/darpa-is-building-a-portable-atomic-clock-with-trillionth-of-a-second-accuracy" data-ob-template="InterestingEngineering"></div> </div> <div class="column-right sticky sticky-box"> <div class="adW visible-md visible-lg t-margin"> <div class="adC spBg"> <span class="adL">Advertisement</span> <div class="center-block"> <div class="b-margin-10" id="div-gpt-ad-interestingengineeringcom38241"></div> <div id="div-gpt-ad-interestingengineeringcom38242"></div> </div> </div> </div> </div> </div> </div> </div> <div class="container"> <div id="next-content"> <a href="https://interestingengineering.com/a-new-bill-could-ban-all-crypto-transactions-in-the-us" title="next" class="next-content"></a> </div> </div>  <footer id="site-footer" class="container-fluid"> <div class="footer-top-wrapper"> <div class="container"> <div class="footer-column-left clearfix"> <nav id="footer-ie-nav"> <span>INTERESTING ENGINEERING</span> <div class="centered-nav"> <ul class="simple-nav"><li><a href="https://interestingengineering.com/about-us">About Us</a><li><a href="https://interestingengineering.com/advertise">Advertise</a><li><a href="https://interestingengineering.com/jobs">Jobs</a><li><a href="https://interestingengineering.com/newsletter">Newsletter</a><li><a href="https://interestingengineering.com/contact-us">Contact Us</a></li></ul> </div> </nav> <nav id="footer-main-nav" class="hidden-xs"> <span>CATEGORIES</span> <ul class="simple-nav"> <li><a href="https://interestingengineering.com/innovation" title="Innovation">Innovation</a></li> <li><a href="https://interestingengineering.com/science" title="Science">Science</a></li> <li><a href="https://interestingengineering.com/culture" title="Culture">Culture</a></li> <li><a href="https://interestingengineering.com/health" title="Health">Health</a></li> <li><a href="https://interestingengineering.com/transportation" title="Transportation">Transportation</a></li> </ul> </nav> </div> </div> </div> <div class="footer-bottom-wrapper"> <nav class="container"> <span class="copyright">© Copyright 2021 | Interesting Engineering, Inc. | All Rights Reserved</span> <div class="footer-pp-menu"> <ul class="simple-nav"><li><a href="https://interestingengineering.com/terms-of-service">Terms of Service</a><li><a href="https://interestingengineering.com/policies">Policies</a></li></ul> </div> </nav> </div> </footer> <div id="cookie-warning"> <div class="container"> <button class="cookie-warning-close">x</button> <span class="pull-left"> We use cookies to ensure you get the best experience on our website. Please <a href="https://interestingengineering.com/privacy-policy">review our Privacy Policy</a> for more information and/or to change your cookie settings at any time. If you continue to use this site, you consent to our use of cookies. </span> <div class="cookie-warning-btn-wrp"> <a href="https://interestingengineering.com/privacy-policy#settings" class="btn btn-warning">COOKIE SETTINGS</a> </div> </div> </div>  <div class="modal fade" id="newsletter-modal" tabindex="-1" role="dialog"> <div class="modal-dialog" role="document"> <div class="modal-content"> <div class="modal-header"> <button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true">&times;</span></button> </div> <div class="modal-body text-center newsletter-container"> <div class="header-container"> <h3 class="h1">Stay on top of<br>the latest<br>engineering news</h3> </div> <form method="POST" action="https://interestingengineering.com/subscription?utm_source=popup_signup_box&amp;utm_medium=email_submit&amp;utm_campaign=Newsletter_popup_box" accept-charset="UTF-8" class="text-center"><input name="_token" type="hidden" value="DnAWwIDm8wloaqFoWX7GChOJBZ2lQgjYrFKCEBF2"> <label class="input-group"> <input class="form-control no-border" aria-label="Email" placeholder="Enter your email address" name="email" type="email"> </label> <button type="submit" class="btn btn-success newsletter-submit no-border popup-sub-btn" name="submitbutton" value="CANCEL" data-push-category="Daily Newsletter Popup">SUBSCRIBE</button> <p class="ua-nl ng">By subscribing, you agree to our <a href="https://interestingengineering.com/terms-of-service" target="_blank">Terms of Use</a> and <a href="https://interestingengineering.com/privacy-policy" target="_blank">Privacy Policy</a>. You may unsubscribe at any time.</p> </form> </div> </div> </div> </div> </main>    <script defer src="https://assets.interestingengineering.com/assets/plugins/bootstrap/js/bootstrap.min.js"></script> <script defer src="https://assets.interestingengineering.com/assets/plugins/iziToast/dist/js/iziToast.min.js"></script> <script defer src="https://assets.interestingengineering.com/assets/plugins/stickyfill.min.js"></script> <script src="https://www.dwin2.com/pub.649979.min.js"></script> <script src="https://assets.interestingengineering.com/assets/plugins/jquery-ias.min.js"></script> <script src="https://assets.interestingengineering.com/assets/plugins/sly.min.js"></script> <script> $(function() { if($('.article-bottom-ad').length) { $(window).on('resize scroll', function() { var abAd = $('.article-bottom-ad'); if (abAd.isInViewport()) { if(abAd.data('is-active') != '1') { setEvent('Sponsored (Banner)',abAd.find('a').data('title'),'Impression'); abAd.data('is-active','1'); } } }); } $(document).on('click touch', '.trending-item > a', function(){ window.dataLayer.push({ 'event': 'gaEvent', 'Category': 'More at Interesting Engineering Unit', 'Label': $(this).text(), 'Action': 'Click', 'nonInteraction': true }); }); $(document).on('click touch', '.trending-topic-title', function(){ window.dataLayer.push({ 'event': 'gaEvent', 'Category': 'More at Interesting Engineering Unit', 'Label': 'More at Interesting Engineering', 'Action': 'Click', 'nonInteraction': true }); }); $.displayNewsletterForm = function() { $('.arrow-down').toggleClass('active'); $('#newsletterContent').slideToggle('fast'); setEvent('In Article Newsletter Unit','CTA Title','Click'); }; var categoryMenu = $('.category-menu'); if($('.sub-category-list').length) { $('.sub-category-list').width($(window).width() - $('.category-name').width()-20).show(); categoryMenu.width($(window).width() - $('.category-name').width()-80); var sly = new Sly(categoryMenu, { horizontal: 1, itemNav: 'centered', activateOn: 'click', mouseDragging: 1, touchDragging: 1, releaseSwing: 1, activatePageOn: 'click', speed: 300, elasticBounds: 1, dragHandle: 1, dynamicHandle: 1, clickBar: 1, prevPage: $('.controls').find('.prevPage'), nextPage: $('.controls').find('.nextPage') }).init(); var $pos = 0; sly.on('moveStart', function (eventName) { if($pos < sly.pos.dest) { setEvent('Category Navigation Bar','Right Arrow','Click'); $pos = sly.pos.dest; } else if($pos > sly.pos.dest) { setEvent('Category Navigation Bar','Left Arrow','Click'); $pos = sly.pos.dest; } }); $('.category-menu > ul > li > a').on('click',function(){ setEvent('Category Navigation Bar',$(this).text(),'Click'); }); } if($('.sub-category-list').length) { $(window).on('resize scroll', function() { $('.sub-category-list').width($(window).width() - $('.category-name').width()-20); categoryMenu.width($(window).width() - $('.category-name').width()-80); sly.reload(); }); } }); $(window).on("load", function() { $('#sticky__sidebar').height($(document).height() - ($('#site-footer').height() + 234)); }); var iasPush = jQuery.ias({ container: '.ias-push', item: '.ias-push-item', pagination: '#next-content', next: '.next-content', delay: 0, negativeMargin: 200 }); iasPush.extension(new IASPagingExtension()); iasPush.extension(new IASHistoryExtension({ prev: '.prev a' })); iasPush.extension(new IASNoneLeftExtension({ html: '<div class="container tb-margin-10"><a disabled class="btn btn-lg btn-primary load-more black-bottom-shadow">{text}</a></div>' })); iasPush.extension(new IASSpinnerExtension({ src: 'https://assets.interestingengineering.com/assets/img/loading-blocks.svg' })); iasPush.extension(new IASTriggerExtension({ html: '<div class="container tb-margin-10"><a class="btn btn-lg btn-primary load-more black-bottom-shadow">NEXT ARTICLE</a></div>' })); iasPush.on('load', function(event) { c = c+1; event.url = event.url + "?c="+c; }); iasPush.on('rendered', function(items) { $(items).each(function() { var $this = this; var $contentData = $($this).find('.content-title'); var url = $contentData.data('url'); var title = $contentData.text(); myLazyLoad.update(); OBR.extern.researchWidget(); }); $('#sticky__sidebar').height($(document).height()); setEvent('Article','Next Article Button','Click'); dataLayer.push(gtmData); }); </script> <script defer src="https://assets.interestingengineering.com/assets/js/main.min.js?v=15"></script> <script> $(function (){ $(document).on('click touch', '.cookie-settings', function(){ $('#cookie-warning').hide(); __cmp('displayConsentUi'); window.dataLayer.push({ 'event': 'gaEvent', 'Category': 'GDPR Cookie Bar', 'Label': 'Settings Button', 'Action': 'Click', 'nonInteraction': true }); }); }); </script> <script> $(window).on("load", function () { setTimeout( function() { $('#newsletter-modal').modal(); $('#header').css('z-index',1000); setEvent('Daily Newsletter Popup','Popup Impressions','Impression'); }, 30000); $('#newsletter-modal').on('hidden.bs.modal', function (e) { $.get( "/setNewsletter"); setEvent('Daily Newsletter Popup','Close Button','Click'); }); }); </script> </div></body> </html>